So we seriously need a forum for DukaPress support. Please know that we’re on it.

In the meantime, please report bugs by listing them here:

492 Responses

  1. fred says:

    The “jquery.fancybox-1.2.1.pack.js” of dukapress was difeerent from the “jquery.fancybox-1.3.pack.js” of my template. I have pasted the last one into the first and everything is ok now.

    enjoy !

  2. Erez says:

    When I type Hebrew characters in the order fields, then it replaced with ? in the order logs

  3. Elizabeth says:

    I am using a clean install of wp & newly installed dukapress. I can create products and complete orders as a “customer” but the order log does not show anything. Any ideas?

    WP 3.1

    • Elizabeth says:

      Ok, I figured this out. I had a problem with the shipping set-up b/c I included the $ in the amount. I really think I should have received an error message here before it tried to save it. It would also be great if basic formatting instructions were included right at the fields.

      I also would like to see the order information have the decimal place and cents, not just rounded to the dollar amount. It shows up under the total dollar amount, but it should be there under the price column and total amount at all times.

    • Elizabeth says:

      Just curious ~ Do you actually use DukaPress for selling your premium add-ons b/c I don’t see PayPal express offered and that’s what you’re using?

  4. Jen Juhasz says:

    Hi – Just installed DukaPress. We’re using Thesis theme. I read your blog post and made the recommended change from 30 to null, which definitely helped.

    However, still several challenges: 1) New products don’t appear on pages where I insert the code: [dpsc_grid_display]; 2) They don’t appear in the product widget which is currently installed in our Right-hand column; On the one working product page, the Add-to-Cart button is cut off on the bottom.




    • Jen Juhasz says:

      Just realized I didn’t give you much to go on. The working product page is: http://missmentor.com/products/miss-mentors-little-black-book-of-grammar/.
      I’ve tried using the code: [dpsc_display_product buy_now=”yes”] as well, and that doesn’t even change the Add to Cart button to Buy Now, and the Add to Cart button remains cut off. Ideas?

      For the overall product page where I’d like a grid to be displayed: http://missmentor.com/books-and-courses/ I’ve inserted the code [dpsc_grid_display category=โ€1โ€ total=”12″ column=”3″ per_page=”4″ type=”duka” order=”DESC”] to see if I could get any kind of grid to display, and nothing appears (I made sure Category 1 was selected with the product as well.

      On both of these pages you can view the product widget on the right-hand column, which remains blank regardless of the published product. Any response would be greatly appreciated!


  5. Herman says:

    I have a bug. I have the shipping pro plugin installed, with a discount code enabled.

    The Bug.
    If you choose your shipping rate the table updates with the new shipping rate and total. So far so good.
    If you then enter and check a discount code, Valid or not, it cancels the shipping rate from the table. If the customer then pays, they pay for the product without the shipping charge. I’m trying to fix it but my JavaScript knowledge is non existent.

    I have my dukapress installed on a localhost installation, but you can see the same error here http://www.lilybelle.co.uk/checkout/
    You’ll obviously have to put some items in the cart to check it.

    • Kelvin says:

      Hello Herman, which version of Shipping Pro are you using?

      We fixed this issue a while ago. Try here and see that it is fixed. ๐Ÿ™‚

      Please do use the latest version of Shipping Pro – it contains important security fixes. We’ve been sending them out to people who bought the plugin. If you have not received the updated versions, kindly email us – duka(at)dukapress.org. Preferably email telling us something (perhaps your PayPal email?) to show that you have purchased Shipping Pro.


  6. david says:


    The product options are not working during checkout, If I choose from my drop down list and click add to cart the loading icon pops up but nothing ever goes into the cart..

    Also in the backend after I have added one option name like weight, It wont let me add another like color…

  7. david says:

    Sometimes the first time you land on the site, it will let you get an item into the cart, but never twice.. I think you may be catching it before another plugin loads a scrip that breaks it. again Im talking about adding items to cart by selecting an option from the drop down list. Like size large. I dont have a clue how to fix this.. Seems like every plugin in wordpress breaks another plugin.

  8. Justin says:

    Thanks Kelvin and team for a very good product and amazing support, this website http://www.juicetoyou.net has the dukapress shopping cart with a lot of customization.

  9. Curtis says:

    I am trying to add products, and have succeeded, but when you add them to the cart, and the try to go to the cart, there is nothing on the page?



  10. Dear Kelvin, Iโ€™ve got a problem for editing product. Iโ€™ve add a product, and it could be displayed well. But somehow, I canโ€™t edit the product options. Iโ€™ve tried different ways, but I cant managed to remove one/both of the productโ€™s price (i could change it though), and canโ€™t add/remove dropdown options.
    Is it a bug or thereโ€™s something wrong with my dukapress /setting?

    PS : right now Iโ€™m using WordPress 3.2.1 and DukaPress 2.3.1.

  11. Btw, I’ve found another bug. I’ve added a product and it appears just fine. But I dont know why, after I edited my product page, it wont shown. Just the description.

    I’ve checked and re-typing the [dpsc_display_product] command several times, but it still wont appear. But amazingly, I’ve tried to add another product and it works just fine.

    Anybody know how to fix this?

    PS : In the product page (user view), I’ve look at the code with firebug, and there’s dpsc_product_main_container, dpsc_image_container, and dpsc_content_container class. But just the div, there’s no picture and such

  12. Gintas says:

    Hi, nice plugin. Although have a lot of job with translation into LT and should use only inguire mode. But images don’t apear with Dukapress version when upgraded to 2.3.1 or 2.3.2. Finally found: Just in Duka 2.3.1 replace through FTP timthumb.php from older version 2.2. Then all pictures apear again. But dont know why all working with older timthumb.php and where is the bug. Any ideas?

  13. Callie says:

    I purchased the shipping pro, but can’t get it to work. Using the following example-the shipping rate calculates as $5.00 no matter what.


    I even tried this way:

  14. Chromaloop says:

    There is a bug in the Shipping Pro plugin. When you add certain countries with an apostrophe in the name, such as “KOREA, DEMOCRATIC PEOPLE’S REPUBLIC OF”, the countries do not become available when you select the associated shipping region on the checkout page.

  15. dukapress user says:

    this plugin is great, have had to do some fixing with the code to get around certain stuff, i just have one question. Why does the “empty cart” link only work when logged in, once a user logs out the cart does not allow them to empty the cart. is there a code fix for this. looking at dp-widgets.php you guys have a # as the link, it works when im logged in but not when im logged out. this is important and i would like to get this fixed asap to get my cousins shop up. your help would be appreciated.

    • Kelvin says:

      Hi. We’re working very hard to solve the issues with the Empty Cart. Please give us a while.

      Also, please have a look at dukapress.org/demo which runs on DukaPress 2.3.3 – when you are there, you can use “Empty Cart” without being logged in

      • dukapress user says:


        i am using duka 2.3.3 and wordpress 3.2.1 i have the problem with ie9 ie8 firefox 6 and so on. thanks for your help.

      • Peter says:

        Same issues here. However, it works in Firefox 7.0, but not in IE and Chrome.

        • dukapress user says:

          I havent got it to work in any browser yet, but i am sure this is just a bug. i just dont have the time to look for it right now. i did a quick fix for the issue when it does not display images in grid mode (timthumb security issue). if it had not been for that i would not have been able to use this plugin the way i wanted to. i wish they could get this one done soon so that portion of the cart works and this would be a real cool plugin

      • dukapress user says:


        i tough that this problem was caused by my theme. i went and checked out this theme


        and guess what?

        The empty cart button does not work their either.

        I will just wait for this bug to get fixed but other than that everything working, have been testing with paypal sandbox. One thing i did notice is not ALL emails are getting sent, the one that i noticed was the order placed email to the client not going out but admin gets all emails. will continue to test over the weekend and report any other issues

        • Kelvin says:

          To fix this on your own, do the following:

          In php/dp-cart.php line number 128 change:
          add_action(‘wp_ajax_no_priv_dpsc_empty_your_cart’, ‘dpsc_empty_cart’);
          add_action(‘wp_ajax_nopriv_dpsc_empty_your_cart’, ‘dpsc_empty_cart’);

          This should do it.

          We’re also going to release a bugfix offocially in the next few hours.

        • Kelvin says:

          version 2.3.4 fixes this ๐Ÿ™‚

  16. aigatou says:

    I’m using WordPress 3.2.1 and current latest version of DukaPress 2.3.3

    1. Check-out fields “name” and “surname” does not accept cyrillic symbols (Error: Please write only text here)

    Screenshot: http://img11.imageshack.us/img11/5775/96047263dff846dd811a18b.png

    2. “Order Log” does not display any order information besides name and surname. I guess there is should be displayed an address, city etc

  17. Shaner says:

    Hey, I have been trying to figure out how to properly use the “buy now” feature. I am entering in the short code correctly into the product description, and the buy now button IS showing up in the right spot. However, when you click “buy now” it just loads forever and never takes you to the PayPal website. Is there anyone who can help me with this?

    I really think the checkout page is hurting my conversion rate so if I could get people directly to PayPal I would be very happy.


  18. Eric says:

    We are doing some development and are having an issue with IE 8.

    Items are added to a cart and show up in the Cart widget in the sidebar.
    But in IE 8 only, when someone clicks “Empty your Cart” … nothing happens.

    Anyone else experiencing this problem?

    I did a search here but it didn’t return any helpful results.

    • Kelvin says:

      In php/dp-cart.php line number 128 change:
      add_action(‘wp_ajax_no_priv_dpsc_empty_your_cart’, ‘dpsc_empty_cart’);
      add_action(‘wp_ajax_nopriv_dpsc_empty_your_cart’, ‘dpsc_empty_cart’);

      This should do it.

      Official bugfix release coming soon.

  19. Jon Legault says:

    We only have one product on our site, it is for our upcoming pool tournament, but for some reason when I go to the checkout page on my computer it works, but when I use it on any other computer I get an error that says “page not found” Here is the product: http://www.blackdiamondspokane.com/products/spokane-open-at-the-black-diamond-registration/ and the checkout page is http://www.blackdiamondspokane.com/checkout

  20. Stryder says:

    I have found a bug on my site. when using worldpay as payment type, the test values sent to worldpay are wrong. I’ve been trying for four days to get support for this and haven’t received any replies… pretty poor service!

  21. Dan Hernandez says:

    Hi there,

    i have tried making payments via Paypal in my checkout page.

    I completed the order process as a customer. But when I logged in the check my order logs, no invoices were found.. no records.

    I have received the email of the invoice, but no listing in the order log…

  22. Marc says:

    I have a problem with Dukapress used with qTranslate. Everything is OK untill the moment the customer clicks on the link to see the detail of a product. He then is transferred to the default language instead of the right language. I think it has something to do with the permalink. qTranslate normally puts the code of the langauge in the permalink but not with a Dukapress product.
    How can I solve this ?
    Thanks in advance for your help.

  23. Kaloyan Dimitrov says:

    I found one bug in the dukapress plugin. I am using wordpress 3.2.1 with dukapress 2.3.3 installed. I am using world pay as my payment processor. However, it does not work when in live mode – in test mode everything works properly but live mode just does not work. I tried this solution:


    but it is not working for me. Do you have any solution for this situation ?

    I will be looking forward to replying from you.

    • Kelvin says:

      Please try the following:

      Line 234 in dp-payment.php
      if ($dp_shopping_cart_settings[‘worldpay_testmode’] === ‘100’) {
      that ‘100’ needs to be ‘test’.

      Line 277

      the value should be $testModeVal.

      Once done, it should look like:

      Line 234 in dp-payment.php
      if ($dp_shopping_cart_settings[‘worldpay_testmode’] === ‘test’) {

      Line 277

      I hope this helps.

      We’ll release an official BugFix release soon.

      • Kaloyan Dimitrov says:

        Hi Kelvin,

        I did exactly as you told me and it still does not work.
        It only works in test mode.

        Do you have any other solution that I can try ?

        Thanks in advance for your help.

  24. Hi

    My first post so be gentle ๐Ÿ™‚

    I have added a product (with the [dpsc_display_product] shortcode) but I just cannot get the page which has this shortcode

    [dpsc_grid_display category=”1″ total=”12″ column=”3″ per_page=”4″ type=”duka” order=”DESC”]

    to show ANY products… what silly thing am I doing wrong?!



  25. Jack says:

    Hello there. I am setting up a friend’s online shop. I am really loving DukaPress – well done! But there is one problem, as you will see if you have a look at, say, http://www.marigoldgarden.co.uk/shop/?page_id=177. I have a very large background image – it has a portrait format, so it is supposed to extend down far enough to encompass all the content. When I deactivate the DukaPress plugin, it works. It also works, as is, on my mobile phone! I am confused. Please, can you help? I am using the ‘Zen Garden’ theme, which has clearfix – perhaps there is some conflict?

    Many thanks in anticipation. And keep up the good work.


    • dukapress user says:

      I would suggest trying another theme, maybe from wordpress.org first. Make sure the theme you are currently using is compatible with wordpress 3.2.1. If it is not that may be the cause of the problem. Another suggestion is to make sure that all plugins are up to date as well. i really doubt dukapress is directly causing this problem, i really think that it is the theme that might have a bug. I currently have a theme that was designed for wordpress 3.2.1 and dukapress works flawless.

      • Jack says:

        Thank you. I had tried half-heartedly with a couple of other themes, and they seemed to have the same problem – and then when the problem went away whenever I disabled DukaPress, I thought there must some kind of conflict. I have now switched to another theme (NatureFox) and am now proceeding well (fingers crossed!). Thanks for your help.

        • dukapress user says:

          Glad to see things are working out better for you today. Good luck and any other concerns you have please don’t hesitate to ask.

    • dukapress user says:

      I forgot to mention you should really be using the permalinks feature on that site you showed to prevent any hackers from attempting to SQL INJECT your friends site.

  26. Megan says:

    When I use the short code [dpsc_display_product] on my products page my picture doen’t show up. I have to insert my picture directly into my product description. Any suggestions?

  27. Sid says:

    Hi there,

    Thanks for a kool and wonderful plugin for small websites like ours. We have been planning to migrate to WordPress and your plugin seems to have enhanced our plans.

    As we are into development and hosting, we do not have much products other than these and as currently ours is not a WP site, we are developing the siteon WP offline(not on any server). Today, we installed the plugin and everything seemed smooth.

    Unfortunately when we tried using the Paypal (not the sandbox, but a real Merchant Paypal Id) the customer (or buyer) got a bunch of emails after payment. We were earlier experimenting with wp-ecommerce from another firm but they too had this issue and so we had to drop the WP idea on the live site. But we really would appreciate your help and would love to have the site on WP.

    For the Dukapress Plugin, we set The IPN to off and also the Auto Response to Off based on your FAQ. But still, the concern is the fact that the buyer is getting a bunch of emails for just one online purchase of webspace(which we believe is a digital product).

    Any help or advice would be beneficial. Also, please put up a page on the documentation to guide us with correct settings on Payment gateways – the forum is much awaited and we wish you good luck on the Plugin.

  28. Sid says:

    Hi There

    I have another query now (in addition to the one above). I did implement this plugin on another website here – http://www.sidsworld.info – and tested it out with the Sandbox that I have. The Process of Payment and emails doesnt get Automated. I mean, if you buy any product and even Pay out, the email with the links is not sent that moment. I have tolog-into the dash board, set the status to Paid and then Click on the Invoice Number to open and then from there click the Send Paynment Notification email.

    Is this the normal way out here or there is something that I am missing which can help in getting this automated?


  29. Al Cain says:

    I have a bug related to product variations. When I add any simple product variable… e.g. ‘dropdown_option’ ‘Colour|White|Black’ , I can see the options appearing ok on the product page

    …..but the product page also shows this code!!???

    0){ totalLen=String(SalePrice).length; valAfterDec=String(SalePrice).substring(desPos+1,totalLen); if(valAfterDec.length==1){SalePrice=String(SalePrice)+”0″;} } if(String(SalePrice).indexOf(“.”)<0){SalePrice=String(SalePrice)+".00";} //END [Nibha : 20080229] Patch added for missing .00 in case of perfectly round numbers. } } } if(flag==0){SalePriceLabel.textContent=SalePrice;} if(flag==1){SalePriceLabel.innerText=SalePrice;} document.dpsc_product_form_18.dpsc_price_updated.value=SalePrice; }catch(ex){}}

    Can you help – where on earth is this bug coming from?!

  30. Al Cain says:

    Ahh – I think I’ve fixed this bug (immediately above).

    When I viewed a product page (effectvely a duka post), I could see a few rouge characters showing on the front end: “<!–"

    If you look in file: DukaEleven: 'single-duka.php' you will see these characters on Line 17:

    Basically I just closed off this ‘unquote’ thus:

    I think this was breaking some javacsript on the page, hence the horrible code that was originally showing in my post above.

    Seems ok now.

  31. Al Cain says:

    Unfortunately this page won’t let me paste-in html code, so my solution doesn’t display properly above.
    But look at Line 17 of ‘single-duka.php’ and you’ll see what I mean.

  32. Chris says:

    Please excuse my ignorance but I am having some problems getting the product page grid display to work.

    I have added two products with short codes of the form:

    A beautiful lemon tasting coffee

    and both have custom fields.

    I have then set up a new page and used the short code:

    [dpsc_grid_display category=”23โ€ total=”2″ column=”2″ per_page=”4″ type=”duka” order=”DESC”]

    With 23 being the category id of our two products.

    Unfortunately, when viewing the product page no products at all appear on this page.

    Any help you can give would be much appreciated.



  33. Ryan says:

    WP version: 3.2.1
    DP version: 2.3.4

    DP [dpsc_grid_display] doesn’t seem to work properly with different permalinks settings (ie month and name)

    Steps to reproduce.
    1) Go to settings -> Permalinks -> Change Permalinks to ‘Month and name’
    2) Create Products page with [dpsc_grid_display]
    3) Create several products
    4) Go to Products page. Page appears to be using the archive template and thus shows products in a list fashion (does not show images).

    Another issue occurs when user tries to fix problem by deactivating DP, and selecting a different template to get products page to show correctly.
    Steps to reproduce.
    1) Deactivate DP
    2) Go to products edit page and select different template.
    3) Go to products page and refresh (may or may not show correctly)
    4) Go back and Activate DP
    5) Go to products page and refresh (shows correctly)
    6) Click on a product in page (can’t find the product)
    7) Any new products created will result in WP unable to find page.

  34. Chris says:

    Hi Kelvin,

    Thanks for getting back to me. In light of the comments below by Ryan I’m just playing with the permalinks settings. We had it set up to /%category%/%postname%/ as a custom structure. I’ve changed this to the default permalink setting and the display grid page appears to be working in private mode. Would you expect the permalinks set to the page name to cause this problem.
    Forgot to say previously we are running:
    WP 3.1.2
    DP 2.3.4
    I’m going to update to the latest wordpress as well.
    Thanks again.


  35. David says:

    Hi Kelvin:
    I have DukaPress 2.3.4 already installed and working ok in my webpage, my bug is that DukaPress is blocking my slider, when I deactive the DukaPress plugin then the images in my slider shows up, I am using jQuery Nivo Slider v2.4, any suggestion to fix it?
    Thanks so much for your help, I am so grateful for this wonderful shopping cart, it is simple and effective.

  36. Gintas says:

    Hi, Kelvin.
    Have Dukapress working, but bug is in Inguire mode when setting admin emails. Can not receive custom message’s body and receiving message as smthg was typed in subject place. Name and email, details fine, but smth wrong or not working correctly with these:%enq_subject% and %custom_msg%. Can You check this? Regards and thanks in advance.

  37. Gintas says:

    I will make admin access for You. Regards ๐Ÿ™‚

  38. How do I stop the thumbnails from being displayed at the bottom of an actual product page, next to the [add to cart] button?

  39. Filip says:


    I have problem with empty chart, which is on my site “Isprazni korpu”. When I click on it, it doesn’t work. I can’t empty the chart.
    I use duka press version 2.3.4 and wordpress 3.3.
    Hope you can help me.


  40. Curtis says:

    I have dukapress installed, but I have a couple of downloadable products that are free, and I use paypal for products. The cart sends the users to paypal, but you can’t do a transaction for free on paypal. How do you bypass paypal, but still use dukapress for free products?

  41. When I replace [dpsc_display_product] with [dpsc_display_addcart], my background color in the post page takes over all but the header. Is there any way to fix this? Has anyone else experienced it? I use the DukaEleven theme.

  42. I set up a webshop for my daughter and everything works fine, but nothing is added to the cart when I click add to cart.
    The answer to the POST request says:
    jQuery(‘div.dpsc-shopping-cart’).html(‘Je winkelmandje is leeg.’);jQuery(‘div.dpsc-mini-shopping-cart’).html(‘0 Artikel โ‚ฌ0.00‘);jQuery(‘div.dpsc-checkout_url-widget’).html(‘Je winkelmandje is leeg.’);jQuery(‘form[id=product_form_1213]’).addClass(‘product_in_cart’);jQuery(‘div#dpsc_update_icon_1213’).css(‘display’, ‘none’);

    (Je winkelmandje is leeg means your cart is empty)

    I don’t understand, because we had it working.
    It was after I found out how to add the images that it stopted working.

    • rixeo says:

      Hello Sylvia,
      Please assist me with the website URL so that I can perform afew tests and get to the root cause of why it is not working well. We appreciate that you chose Dukapress and I apologize for not responding to you sooner

  43. I have to apologize for not having updated:
    It works again. It must have been a JavaScript “glitch”. I restarted the browser and everything worked fine.

    Thank you for your offer to help!

Leave a Reply

© 2016 DukaPress. All rights reserved.
Design By Madoido.