Bugs

So we seriously need a forum for DukaPress support. Please know that we’re on it.

In the meantime, please report bugs by listing them here:

492 Responses

  1. Julia says:

    Hi – I’ve got everything working just so, with one exception. The customer receives 2 copies of the email with the subject line “Receipt of Order No: xxxxx,” and containing the invoice.

    I notice that if I refresh the [dpsc_thank_you_page], yet another email is generated. That’s not a problem, but I’d love for the customer to get just one email, as I’m afraid people will think they’re being charged twice.

    http://www.natasharizopoulos.com

    Any ideas what could be causing this?

  2. Steve says:

    What a great application to ad for WP. I really like it.

    My question has to do with testing. I have DukaPress working almost to my satisfaction on a WAMP server not on a internet hosted site. Now I want to test it completely before moving it to my host by making the transactions run thru the PayPal sandbox environment.

    Has anyone connected Dukapress to the Paypal Sandbox environment, and if so how did you do it. I have my account set up on Paypal’s sandbox and have worked with before, I just need to know how to direct DukaPress to the sandbox.

    Thanks in advance, and DukaPress is a really elegant solution to WP e-commerce.

  3. Celine says:

    Hi, I have a problem, all of a sudden when i click on a product i get page not found, i think its the 404 error page. the product page shows the grid absolutly fine with the products on, but the product page cant be found.

    please help!

    • Kelvin says:

      Not a bug πŸ™‚ it is a weird WordPress issue with permalinks and custom post types. What you need to do is go to WP admin under Settings>Permalinks and click “saave” again.

      • Bryce Martin says:

        So I’m building a site for a customer of mine and so far I love Dukapress. The only problem is that I can see the Products page…but I can’t see any of the other pages I create. They all 404 the content…Is this a Dukapress conflict or do you think I probably have something setup wrong? I tried the “save” thing but that didn’t work.

        Also, if you are working with a temp url on hostgator the timthumb mod_sec doesn’t work. I was on with support for over an hour last night and they couldn’t get it to work. It works on my domain, but on the temp domain (ip.add.ress/~cpanelname/) it doesn’t work.

        • Bryce Martin says:

          Ok, here is an oddity that I can’t figure out that is the source of the 404. So I can go to my temp url which is…
          http://174.120.5.220/~kissofna/

          If you click on products the url then becomes…
          http://174.120.5.220/~kissofna/products/

          So far so good. I can see the grid there. Now if I use the menu to go to one of the other pages…. any of them it becomes something like this…

          http://174.120.5.220/~kissofna/products/kiss-me-mascara/
          and I get the 404. If you change the ‘p’ in products to a capital “P” then it the url works! Why? I can’t find any place where /products would be expected to be a capital P…

          • Kelvin says:

            I really doubt whether DukaPress is at fault here because if you click on the links on the Grid page, they seem to work. The issue with the capital P is weird…I have no idea why it could be so. Also, I notice that the page there is not a product?

            Finally, this should help to get the images working: http://dukapress.org/blog/2011/02/19/dukapress-images-not-working/

            • Bryce Martin says:

              Well, I have the global “products” category. I then have the products organized into their proper sub category. I want the sub category page to have the overall product description and then have the grid for that sub category below that.

              Yeah, I think the capital P thing is due to permalinks being case sensitive. I’m just going to have to dig into it and fix it manually.

              As far as the link you gave me… I already gave that to hostgator support the other day. They still didn’t get timthumb working. I’ll just wait until I switch the DNS and see if it is a problem.

              • Bryce Martin says:

                Ok, so I was playing with the site again tonight and I noticed something…. when I change the permalink slug for the “Products” category to “product” all the links for properly as lower case. But as soon as I change the permalink back to “products” it will only find it if I type the address as “Products”. So, since I have seen it recommended to have a single Products category for dukapress I’m wondering if you guys are doing anything special with that specific category name that is causing the issue? These other pages are set as children of the Products page by the way…. if that makes any difference.

                Let me know if you need more info.

                • Bryce Martin says:

                  Hey Kelvin,
                  Any thoughts on this?? The issue is only with the Products category. I manually went into every database file and where the work “products” was, I made sure that it was set to lower case. Even that didn’t work in making the Products go to mysite.com/products Instead it goes to mysite.com/Products

                  I am really leaning towards the idea that somehow dukapress is seeing the Title as a capitol letter and making it go to that instead of the page slug… maybe its a WordPress issue… but it is ONLY Products that causes this…. that is why I’m thinking dukapress.

  4. celine says:

    I cant find the person that helped me, so if its you, thanks, it worked!

  5. Joe says:

    everything worked out of the box except for the ‘send payment’ notification. I click it and get an error. the error states:

    Warning: copy(/home/papi/fimizo.com/wp-content/uploads/dpsc_download_files/http://fimizo.com/files/2011/01/E_Street_Newsletter.pdf) [function.copy]: failed to open stream: No such file or directory in /home/papi/fimizo.com/wp-content/plugins/dukapress/dukapress.php on line 1360
    failed to copy …

    It appears that the tool to locate the file didn’t append the link properly. Any ideas?

  6. Anita E says:

    I can’t get the payment button to work. I tried turning off all my plug-ins, but it didn’t help. I have a client breathing down my neck, so I need to get this fixed ASAP. Any chance I can call you to have you help me trouble-shoot?

    • Anita E says:

      Oops – never mind the phone call. I see now that you’re in another country.

      • Steve says:

        I had the same thing happening for about 3 days.
        1)clear the cache,
        2)DO NOT be logged in as ADMIN, in fact do NOT be logged in at all.
        3)OPen a new browser window, not a tab, a new window.
        4) check out an payment button worked.

        I was having problems and decided to try the crummy IE browser. Guess what it worked. So I was thinking that if IE could work then surely Mozilla could. I think the key is not being logged in as admin. Hope it works.

  7. Mathias says:

    Hi,
    that seems to be the powerful shop extension for WordPress I was looking for. Unfortunately it does not work with BuddyPress installed. Is there a known issue? Settings page and probably other features do not workwhen BP is activated. Could you please give some advice even if it’s not your but the Buddy’s fault.
    Thank you.

  8. Alex says:

    I have a bug corresponding to the ajax routines (when adding to cart or deleting from cart). Can I turn off ajax support for your plugin? I mean that ajax is not so important to me

  9. Nikhil Rishi says:

    HI
    You have built a very clean and awesome plugin for WP.

    I have a couple of questions.
    1. Is it not compatible with buddy press also running? Because when BP is activated, Duka settings are not modifiable.

    2. We would like to sell our product at $4.86 for 1, $7.86 for 2, $10 for 3, $12 for 4, and $13 for 5. Plus a shipping and handling charge of $1.50 for the first product, $0.50 for each additional product.
    How do i do this??

    Please do post a reply for both the questions. I would be eagerly waiting,

    Thanks & Regards
    Nikhil

    • Kelvin says:

      Unfortunately, yes there are issues with BuddyPress. We’re trying hard to isolate and fix these. I am sorry for the inconvenience.

      Right out the box it would be difficult to do what you want, and have described. The best bet would be to modify DukaPress to fit your specific needs. However, what you can do is create different products where you charge 4.86, 7.86 etc etc
      To handle the shipping, use weight classes and set your products weights such that the charges work out to be what you want.

      I hope this helps.

  10. Lubna says:

    Hi, I’ve been trying with the payment options and the only convenient online payment option was through Alertpay, since I’m located in Egypt.

    There is one thing though .. my shop’s currency is in EGP, and I’ve configured the payment option to send in USD currency, but then, on checkout I get this error when directed to Alertpay:

    ——
    We apologize, but the payment button settings are incorrect. The following problems occurred:

    * ap_currency field is invalid.

    If you are a buyer, please inform the seller.
    ——–

    Is this a bug, or am I missing something? please help. Thanks allot.

  11. Lubna says:

    Thanks allot for your replies, one more thing though .. I use the categories widget in my sidebar, but non of the links work .. that is, when I select a category, I get a page not found message.

    • Kelvin says:

      There is a bug in WordPress 3.0 that makes custom post types not show up in archives (categories, tags, etc). A fix for this bug is coming in WordPress 3.1

  12. Andrew W says:

    when trying to hit the make a payment using authorize.net page load error.
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET CLR 1.1.4322)
    Timestamp: Fri, 18 Feb 2011 00:35:10 UTC

    Message: ‘SalePriceLabel1’ is undefined
    Line: 240
    Char: 70
    Code: 0
    URI: https://regulatorbailbonds.com/gear/checkout/

    Message: ‘SalePriceLabel1’ is undefined
    Line: 293
    Char: 70
    Code: 0
    URI: https://regulatorbailbonds.com/gear/checkout/

    Page does not load which makes the payment button seem as if it does not function. Any help would be marvelous.

  13. Rushels says:

    Hi, I appreciate the support here for this awesome dukapress plugin.
    I have encountered a problem where The order notification via mail does not indicate the items ordered. Also the DukaPress Shop Order Log displays a ” No records found!” error.
    What could be the problem?

  14. Brandon says:

    I am having issues with the buttons display they are streched out and cut off halfway through the width wording and everything. and my checkout page is disconfigured any help? thank you http://sincerae.co/?p=71&dpsc_ajax_action=empty_cart

  15. Brandon says:

    Also the layout id disproportioned in the check out and when i click make payment nothing loads?

    • Kelvin says:

      Please add me as an admin => duka[at]dukapress
      I might be able to help fix some things, but the main problem is that your theme’s CSS is messing up the DukaPress CSS. You’re going to have to do some CSS work to fix it all up.

  16. Brandon says:

    also having issues with the make payment button thank you so much for your help! i will def give you guys a great review for you prompt service and willingness to help out us little guys!

  17. Steve says:

    I have an old problem that cropped up either yesterday or overnight. The images that showed up on my products pages have disappeared. For two weeks everything worked fine. Now the product catalog does not show images and the site is live.

    I have changed nothing on the server. No new plugins have been added. I cannot find any logs that would indicate something is broken. I have contacted my hosting service(hostgator) and am having to look into any changes they may have made.

    can DuakPress look into this or contact me. Thanks

    • Kelvin says:

      We use Hostgator too – really nice webhost!!! – so I think that it is most probable they are not allowing timthumb.php to work. Please contact them referencing this: http://dukapress.org/blog/2010/09/23/we-live-in-a-bad-world/

      • Steve says:

        I remember when I first built the catalog pages the images would not show and I did contact HG, but the tech I got acted like everything was fine and they were not blocking anything.I finally figured out the trick to get the images to show up and was pleased. HG is know to push updates on their servers without warning to their clients(me) and sometimes the updates break things. I hope this is the case because my client will surely call me out on this. I just got paid for the site yesterday!
        Thanks Kelvin, great work you do.

  18. Trena says:

    Oh my goodness!! My pics has disappeared! I have tried uploading again and nothing. I too use Host Gator. PLEASE HELP!!

    Also, in regards to the invoice pdf option, I had the box checked after upgrading. It is why I was surprise when I did not get the pdf download button.

    In the mean time I will keep trying to get the pics to show.

    Thanks Dukapress

    • Steve says:

      The Croc’s at Hostgator must be really busy because my first contact to them was 4 hours ago and so far I have only received an auto generated acknowledgment of the ticket I opened. This is strange because 1) most upgrades are pushed on SAT and not FRI. Maybe they are busy looking into things such as this. When I open my ticket I did mention that ‘timthumb’ was the script that put the images on the products page and asked them to check that.

      A quick question to Kelvin and DukaPress, does ‘timthumb’ or DukaPress have any limits to it in the area as to how many products can can be created and entered into WordPress. Right now I think I have about 42 products and was wondering if we are running out of space somewhere? On my host I have an unlimited disk and bandwidth account but maybe WP, ‘timthumb’, or DukaPress could have a limit set somewhere?

      I am just guessing at this and have no knowledge of the true inner workings of the programs or scripts.
      Thanks for the help Kelvin

  19. Fitra says:

    Hi kelvin, I’ve got problem with email notification. The customer receives many copies of the email with the subject line β€œReceipt of Order No: xxxxx,” i’m using bank transfer for payment method.

    so, any idea what could causing this ?

    thanks for help kelvin

    • Fitra says:

      SOLVED ! the problem is you placed “dpsc_pnj_send_mail” in “thank you” page so when users refresh their page, that will generated new email. I have to modified your code to move “dpsc_pnj_send_mail”.

      thanks

      • Steve says:

        Fitra, could you share a little more information about how you modified the code. I would like to stop the second e-mail to the clients as well.
        Thanks

  20. Justin says:

    Hi, I’m setting up a test website and I am having a problem where the order log page displays nothing on the menu screen, also the order log page from back end menu. The customer log shows the orders made but nothing when a particular log is selected.

    Please how can I fix this?

    Your help is much appreciated.

    Best regards
    Justin

  21. Andrew W says:

    I figure I will try this again. would appreciate any help.

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET CLR 1.1.4322)
    Timestamp: Thu, 24 Feb 2011 16:37:01 UTC

    Message: ‘SalePriceLabel1’ is undefined
    Line: 247
    Char: 70
    Code: 0
    URI: https://regulatorbailbonds.com/gear/checkout/

    Message: ‘SalePriceLabel1’ is undefined
    Line: 300
    Char: 70
    Code: 0
    URI: https://regulatorbailbonds.com/gear/checkout/

    Message: Object doesn’t support this property or method
    Line: 33
    Char: 5
    Code: 0
    URI: https://regulatorbailbonds.com/wp-content/plugins/dukapress/js/dukapress.js?ver=3.0.5

    When trying to checkout. I am using authorize.net

  22. Amy Allen says:

    Hi there,

    I am loving DukaPress so far – but am having a small problem with ordering on my products page. I put in the variable Order=”ASC”, assuming that would order my products in ascending price order? But one of my products is consistently listed first, even though it is not the cheapest. The rest are in the correct order.

    Can you offer any advice?

    Thanks so much!

    Amy

    • Kelvin says:

      Oh goodness, I am sorry. We should have clarifies this: the ordering is not by price, it is by post ID. Most probably, in the next version the order is going to be by date of product creation.

      Does this help?

      • Amy Allen says:

        Yes, that is helpful. Thank you! Do you know if it is possible to change the post ID once it has been published? Or should I delete the products and re-create them in the order I want them to appear in?

        Thanks again for your help!

        Amy

        • Kelvin says:

          Unfortunately, the only way is to delete the post/product. However, if you have many products and/or if this would be a pain, I can send a modified version of DukaPress (actually just one line of one DukaPress file is changed) that orders them by the posts’ date. Using post date is easier because you can change it easily – this is a change that will be coming in the very next version of DukaPress. In case you want this, my email is duka(at)dukapress.org

    • Kelvin says:

      As of DukaPress 2.2, the order is by post date and not post ID. Better? πŸ™‚

  23. Trena says:

    Oky-doky I am a bit frustrated. I do not have access to a copy of the invoice.

    No, pdf download button or anything else.

    Please help me. Perhaps it’s a bug.

  24. Can Rau says:

    hey guys pretty nice plugin

    but its not workin probably for me

    after savin a new article all extra values in “dukapress product options” are gone..!?

    and im not able to create a workin product page

    i set up a new page with your short code
    “[dpsc_grid_display category=”1” total=”12″ column=”3″ per_page=”4″ type=”duka” order=”DESC”]”

    tried different cats but there are no articles!?

    ah i tried it in a local xampp system and on my online webspace

    i hope you can help cause i really like this shop

    regards can

  25. atom says:

    tried the newest development version using PayPal sandbox and am getting an error on the PayPal site, so i deactivated the plugin, deleted the files and re-installed 2.2 and am still getting this error. i don’t know if this is a DP problem or not.
    ——————–
    If you were making a purchase or sending money, we recommend that you check both your PayPal account and your email for a transaction confirmation after 30 minutes.

    If you came to this page from another website, please return to that site (don’t use your browser’s Back button) and restart your activity.

    If you came from PayPal’s website, click the PayPal logo in the upper-left corner to return to our home page and restart your activity. You might have to log in again.
    Mayfly::MayflyException: IOException: no response from 10.191.196.196:31067 Backtrace: PPException::PPException(String const &) MayflyBridge::Client::destroy(MayflyBridge::RecordID const &) MayflyCryptClient::Client::destroy(void) CustomerPropertiesCache::destroy_cache(void) User::AuthenticationALIImpl::internal_login_postprocess(WUser *&, String const &, User::UserAuthTokenVO &, OTPCheckType, bool, bool, int) User::AuthenticationALIImpl::login(WUser *&, String const &, String const &, User::UserAuthTokenVO &, OTPCheckType, bool, bool) User::AuthenticationControllerImpl::login_check(WUser *&, String const &, String const &, bool, OTPCheckType, Riprap::WebAppReturn *&, bool, bool, bool, LocaleMessageKey const &) User::WebSessionALIImpl::login(String const &, String const &, Riprap::WebAppReturn *&, OTPCheckType, bool, bool, LocaleMessageKey const &) Rapids::Flows::HostedPayments::DecoratorLogin::execute(Rapids::CGIVars const &) Rapids::DecoratedState::execute(Rapids::CGIVars const &) Riprap::RiprapRapidsGenericFlow::flow_continue_post(Riprap::WebAppContextOrnate const &, Riprap::DispatchInterceptorRegistry const &) Riprap::call_rapids(Riprap::WebAppContext const &, Riprap::RapidsFlowFactory const &, Riprap::DispatchAction const &, Riprap::WebAppReturn const &, String const &, Riprap::DispatchInterceptorRegistry const &) Riprap::dispatch_loop(Riprap::EPRegistry const &, Riprap::WebAppContext const &, Riprap::DispatchAction &, Riprap::WebAppReturn &, String const &, Riprap::DispatchInterceptorRegistry const &) Riprap::dispatch_wrapper(OutputStream &, Riprap::EPRegistry const &, Riprap::WebAppContext const &, Riprap::WebAppReturn const &, String const &, bool const &, Riprap::DispatchInterceptorRegistry const &) gcc2_compiled. main

    • atom says:

      the above may have been do to using the sandbox. i just tried using the normal PP acct and the order is precessed fine.

      the only other trouble i’m having is that i’m always getting a 404 when returning from the PP site to the “thank you” page.

      the page URL works fine:
      http://12bytes.org/?p=470
      the problem is parm that gets added which produces a 404 (i changed the numbers here):
      http://12bytes.org/?p=470&id=20110321635258
      my permalink structure is:
      /%year%/%monthnum%/%postname%

    • atom says:

      last comment didn’t get published…

      getting a 404 when returning from PayPal to the “thank you page”

      the page exists and the URL is correct and the right shortcode is inserted
      the problem is with the added parm to the URI, as an example:
      example.com?p=1&123456
      when PP adds the ‘123456’, the results in a 404

  26. atom says:

    regarding digital downloads, the buyer is able to download the file multiple times! this is not good. i was expecting the temp link to expire after the file was downloaded, or after the time limit if not downloaded. i hope in a future version this is considered and an option is added to kill the link after the file is downloaded. the browser should not be able to cache the file either.

    also, from the one test i did, DP failed to log the order for a digital download. this worked while using the PayPal sandbox, but it’s not working after going live.

  27. atom says:

    12 “payment received” emails after placing one order. IPN is disabled.

  28. Andrea says:

    Unfortunately, I also have a bug with an empty “order log” screen. I use version 2.2 and didn’t change anything at the php.files. The “New order” information e-mails to the admin of the shop (me) and to the customer are working, but if I click on the link in the e-mail to see the order details, there’s nothing – just an empty page!

    Would you please give advice?

    Many thanks!!!

  29. Adrian says:

    Hi,
    Tried to activate your plugin but got the following errors:

    Notice: Undefined index: action in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php on line 11
    Notice: Undefined index: dpsc_ajax_action in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php on line 111
    Notice: Undefined index: dpsc_ajax_action in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php on line 142
    Notice: Undefined index: dpsc_ajax_action in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php on line 421
    Notice: Undefined index: dpsc_ajax_action in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-payment.php on line 19
    Notice: Undefined index: paypal_ipn in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-payment.php on line 794
    Notice: Undefined index: auth_ipn in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-payment.php on line 986

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php:11) in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/dukapress.php on line 19

    Notice: Undefined index: page in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/dukapress.php on line 227
    Notice: Undefined index: page in /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/dukapress.php on line 227

    Warning: Cannot modify header information – headers already sent by (output started at /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php:11) in /home/f/a/farmwebsite/public_html/wp-includes/functions.php on line 851
    Warning: Cannot modify header information – headers already sent by (output started at /home/f/a/farmwebsite/public_html/wp-content/plugins/dukapress/php/dp-cart.php:11) in /home/f/a/farmwebsite/public_html/wp-includes/functions.php on line 852

    Can you help?

    rgds
    Adrian

  30. Darby says:

    Hi,

    I am having a couple of problems.
    First: I am selling fabric and other quilting related products. At the moment, we have only loaded fabric onto the site. My categories at the moment have two top level parent categories: Fabric and Notions. If I click on any of the categories, including Notions, I get the appropriate page to show. However, if I click on Fabric, I get a blank page. When I loaded each fabric, I check the “Fabric” box, as well as the appropriate child category, such as “Batik”. They all display just fine, except for “Fabric”. The other top level category, “Notions”, displays just fine.

    The second problem I am having is getting the thumbnail to disappear next to the larger product. I saw how to do it in an earlier post, followed the directions, and nothing happened. I can’t make it work, although my CSS skills are just this side of nil.

    One other thing, one my products, and only one, has two little thumbnails off to the left, not one. It’s weird.

    Any ideas?

    Thanks.

  31. Dario says:

    Hi!

    When adding variations to a product the Add To Cart button stops working…
    It keeps loading forever.

    However, when there are no variations it works perfect.

    Any ideas?

    Using last version of Dukapress

    Thanks!!

  32. darby says:

    I am having some interesting issues with the invoice generated in the orderlog.

    1. How can I change the photo that appears at the top of the form.

    2, Our product descriptions are pretty long, and don’t want to stay in the Product Name box; they just continue right through the other three boxes, making them virtually unusable.

    Can anything be done about this short of changing our product descriptions?

    • Steve says:

      What I did was at the top of the product page inform the visitors to click on the product image to be taken to the product post(page) to read a more detailed description.
      I know that is probably not the answer you want to hear but that is how I worked around the lengthy descriptions.
      Cheers

  33. Darby says:

    I think that is probably going to be the solution. We sell fabric and have some pretty long descriptions. We really need to find a way to display all of the information in custom fields, and just put the item number in the description. I don’t really know how to set up custom fields at this point though.
    If we were to do this it would actually result in a better layout and a much less clunky look, so maybe it really was the answer I wanted to hear. πŸ™‚

    Thanks for your input.

    Darby

    • Steve says:

      You are welcome. It seems that each piece of software I get, there is learning curve with the many ways to work around something. WordPress premium themes for example. I started using them and had to re-learn a ton of programing, nothing works perfectly out of the box though. I find that Kelvin and the DukaPress team to be one of the better ones once it is setup and functioning.

  34. Justin says:

    For some reason when I choose “enable pdf generation” in the settings, the button to submit payment stops working. I dont have the option to get a pdf either. When I uncheck the enable pdf generation, everything works again. Any ideas what could be going on?

    • Kelvin says:

      This is the very reason why we made the PDF optional. It seems that option does not work on all servers. I’m not entirely sure what is wrong – but something on your server prevents the PDF from being generated.

  35. Elizabeth says:

    Hey….I’m having issues with the links to the products not working…The permalinks work for everything else.

    Currently, the link takes me to….
    http://dillardgardens.com/4bcocms/products/test-2/

    However, it should go to
    http://dillardgardens.com/4bcocms/index.php/products/test-2/

  36. Dario says:

    Hi!

    IΒ΄m trying to populate the user details in the checkout form…
    It is supposed to work when the user is logged in and the “registration on” is checked in the settings for dukapress.

    But I still canΒ΄t get the info populated there..

    Any ideas?

    Thanks!!

    Dario

    • Dario says:

      Also, I bought the Shipping Pro and found an issue

      Shipping pro is activated and there are rules to calculate shipping cost

      1) Add a product the cart
      2) Go to checkout
      3) Select a shipping option
      It calculates shipping and final price
      4) Update quantity for a product
      Shipping cost it removed and it is not recalculated.

      Please take a look on it.

      Tahnks,

      Dario

    • Kelvin says:

      Please please a dummy order at http://dukapress.org/demo to get an idea of how it works. When you order, you will be registered as a user and when you next place an order AND if you are logged in, your user details will be on the checkout page pre-populated.

  37. Jan Battem says:

    Hi Guys,

    If I am in my ‘DukaPress Shop Order Log’ and click on the ‘Invoice number’ I see my ‘Transaction Details for Invoice No…..’

    Then I only see the link ‘Send Payment Notification.’

    And I don’t see the link ‘Click here to download your Invoice.’

    This link only appears after I click the link ‘Send Payment Notification.’

    This seems not rightt to me????

    Thanks, Jan.

  38. Elizabeth says:

    How can I test the shopping cart & not process an order through PayPal. I don’t see a test or dummy gateway.

    Thanks

  39. Jenn says:

    I’m testing digital product delivery and am not getting anywhere with it.

    I’ve ordered both my ebooks, but neither have been delivered to my alt. email address.

    Is there specific documentation about how to set up delivery of the digital products?

  40. Elizabeth says:

    Have you fixed the javascript error that keeps the arrows spinning on an iis 6 platform? I really need to move forward with my project. Thanks.

    http://dillardgardens.com/4bcocms/products/

  41. Jenn says:

    Hi Parshwa, I really don’t know, or know how to check that…..

  42. Trena says:

    Hello, I built my site in FireFox. However, when viewed in IE or Safari it doesn’t load correctly.

    How do I fix?

    Thanking you in advance

  43. Elyas says:

    Hi Kevin,

    Thanks for a great plugin!

    The variation prices don’t show correctly in the cart. Have you faced this issue before?

    http://uaebizleads.com/email-marketing/egypt-2/

    Thanks,
    Elyas

    • Kelvin says:

      Your variations look fine…what exactly is wrong?

      • Elyas says:

        On closer look you will notice the the variation selected does not get reflected in the price above or in the item added to the cart. The price and the product description differ.

        • Kelvin says:

          Unfortunately, this is how it works. Have a look at our demo: dukapress.org/demo

          You have a base price and then the variation is added onto that. I am sorry for the inconvenience this causes you.

  44. Suzy says:

    Hi There,

    I have the add to cart button working fine but [dpsc_display_product buy_now=”yes”] also displays the add to cart button. How do i get it to show the buynow button?

    Thanks
    suzy

  45. Jenn says:

    I’ve come up some weird inconsistency on my makeup site.

    The layout here is perfect and exactly what I want.
    The photo on left, with the buy button and drop down right next to it on the left.
    http://paintedlaydiesmineralmakeup.com/products/f1-6-foundation/

    However, the next section is off.
    The photo is on the left but the buy button and drop down are below the photo and to the right.
    http://paintedlaydiesmineralmakeup.com/products/f2-9-2/

    I used exactly the same layout, even just copied the html code from the first to the second. I’ve been playing all day and can’t get the rest of the layouts to match the first.

    No matter where I’ve placed the short code, it is off set (not in the same horizontal line).

    Any ideas why it’s doing this?

    • Kelvin says:

      Could you possibly add me as a temporary admin to try solve this? duka(at)dukapress.org is me

      • Jenn says:

        Actually, Kevin after messing with it all day yesterday, I checked last night and the problem was no longer there.

        I have no idea why. But it appears to be fixed.

        I still have an issue with another problem on another site and will go back to find my other bug report.

  46. Dave says:

    Hi Kelvin,

    First off, I wanted to thank you for all of your hard work on this amazing plug-in!

    I am actually struggling with an issue that seems to have been repeated on previous posts above, but I am unable to get permalinks working correctly with individual product page posts. I am working from a local copy of the website using MAMP and have a majority of the functions working so far. The grid gallery works perfectly, but the individual product pages refuse to show up.

    In my index file, I am setting a conditional for “if (is_page(XXXX)) { include(TEMPLATEPATH . XXXX ); }”, to basically insert a page based on the slug/page name. I noticed the plug-in will automatically create the slug ‘products’ and associate any products as subpages. I tried setting my conditional to open certain template files based on if “products” is_page = true, but with no success.

    From my understanding, this could be a bug with the WordPress 3.1XX version, but I just wanted to make sure this was not a user error on my part.

    Thanks again!

    • Dave says:

      Hi Kelvin,

      Just wanted to let you know I resolved this matter quickly. It was a user error on my part, since I did not use, nor setup the single.php post pages to house the product subpages. Seems like I need to study up on how to use WP a bit more!

      • Dave says:

        Hi Kelvin,

        Perhaps I spoke too soon.

        This seems to be yet another error I see some people running into, but I am having issues with the “empty cart” function now. When I insert products from the product grid page into the cart and empty it, it empties fine. When I empty products I have inserted from the pages from a single.php template files, it sends me back to the main page.

        Just FYI, I am currently using the Custom Post Templates plug-in to associate the different product buyer pages with different design templates (it replaces single.php with user selected template files), but the content overall is the same. Could this be part of the problem?

  47. Justin says:

    Hi,
    When trying to add a text logo to the pdf, it has to be reduced so much that it comes out really blurry. does anyone have an idea how to make it small enough? Or a code that could be used within dukapress to re-size a bigger image to the correct proportions? Amazing plugin by the way. Thank you!!

    • Kelvin says:

      The easiest way to add a logo to the PDF is to replace the default logo image (inside DukaPress images folder) with your own.

      • Justin says:

        Hi Kelvin,
        That’s what I was doing but the picture size is so small and such low resolution that any text logo that’s entered is really blurry. Is there any way to use a larger picture and then have dukapress re-size the image to the correct dimensions?

        • Kelvin says:

          I’ve been looking into this but I haven’t gotten an immediate solution. The images dimensions are 200×99. it is not extremely small – right? Please try work with it while we coem up with a fix.

  48. Bryce Martin says:

    I cannot for the life of me get thumbnails working for the products. If you go to http://kissofnature.net/products
    the first two items in the grid have pictures on them (didn’t put the rest since I don’t have these working yet).

    I contacted hostgator and they have the domain whitelisted per mod_sec. But to no avail… it works great on my test at http://bravobryce.com/kon/products but for some reason this install just doesn’t want to do it. Any thoughts??? Is there a log of where timthumb writes that it was active?

  49. fred says:

    Hi,

    One more time thank you for this great plugin !

    I have just instal it on a new site but when I activate dukapress it cause javascript issues on all the site (cufon, shadowbox…) and the image effect don’t work on product pages.

    can you help please ?

Leave a Reply

© 2017 DukaPress. All rights reserved.
Design By Madoido.